Will LEM be available prior to Jan 20 2019 TLE? [Case Solved

Support for the Lunar Eclipse Maestro photography software.

Re: Will the planned LEM be available prior to Jan 20 2019 T

Postby Rgalloway11 » Tue Jan 15, 2019 9:59 pm

I have not tried it yet, but I will when I get home from work later on today. I am running High Sierra....we will see in a few hours.
Rgalloway11
 
Posts: 8
Joined: Wed Jan 09, 2019 2:16 am
Location: Indianapolis, IN, USA

Re: Will the planned LEM be available prior to Jan 20 2019 T

Postby Rgalloway11 » Wed Jan 16, 2019 12:40 am

Xavier - here is my update....
I can get the LEM software to load and start running on my MacBook Pro. As soon as I connect and turn on my Canon 5D3 or 6D, LEM immediately crashes.
I am running High Sierra v 10.13.6
Rgalloway11
 
Posts: 8
Joined: Wed Jan 09, 2019 2:16 am
Location: Indianapolis, IN, USA

Re: Will the planned LEM be available prior to Jan 20 2019 T

Postby xjubier » Wed Jan 16, 2019 5:52 am

Rgalloway11 wrote:Xavier - here is my update....
I can get the LEM software to load and start running on my MacBook Pro. As soon as I connect and turn on my Canon 5D3 or 6D, LEM immediately crashes.
I am running High Sierra v 10.13.6

OK, two things there:

1) High Sierra has a crashing regression and Apple never fixed it even though my bug report was acknowledged and Apple could reproduce it every time... The solution to this Apple induced crash is to use an empty memory card before connecting a camera, or else use another main OS release such as Sierra or Mojave which don't have this Apple regression!

2) Kathleen crash under Mojave is caused by some strange behavior from Canon's own SDK (doesn't happen with my Nikon proprietary code). Luckily this part of the code is called only by some of my beta code (one day it will be integrated in a final release as it allows to detect and expose some camera properties Canon doesn't document or use in its SDK), so I've shunt it for now and did build a new beta release with the same name and version number but a different checksum.

The download link stays the same, the version as well but the checksum is different, so just download again and then install one more time.

Note: all those who downloaded the previous beta should replace it. So if you downloaded before Wednesday January 16th at 05:00 GMT then download and install again.
xjubier
Site Admin
 
Posts: 314
Joined: Wed Oct 01, 2008 12:35 pm
Location: France

Re: Will the planned LEM be available prior to Jan 20 2019 T

Postby Rgalloway11 » Wed Jan 16, 2019 2:00 pm

OK, I'll try the new beta version again this evening. I've got my fingers crossed...
Rick
Rgalloway11
 
Posts: 8
Joined: Wed Jan 09, 2019 2:16 am
Location: Indianapolis, IN, USA

Re: Will the planned LEM be available prior to Jan 20 2019 T

Postby xjubier » Wed Jan 16, 2019 11:13 pm

Rgalloway11 wrote:OK, I'll try the new beta version again this evening. I've got my fingers crossed...
Rick

It's working for Kathleen, so you should be fine.
xjubier
Site Admin
 
Posts: 314
Joined: Wed Oct 01, 2008 12:35 pm
Location: France

Re: Will LEM be available prior to Jan 20 2019 TLE? [Case So

Postby Rgalloway11 » Thu Jan 17, 2019 3:42 am

It took doing some experimenting, but I was able to finally get my 5D3 and 6D to load the script and do the hardware setup without crashing. I had to turn on my camera, take out the SD card, close the card door. Then turn on the LEM hardware setup and then plug in the USB cable and then reinsert the SD card into the camera. Sounds crazy, but it worked finally.

Thanks so much again! I am hoping for clear skies, but it is going to be bitterly cold here in Indianapolis Sunday evening.
Rick
Rgalloway11
 
Posts: 8
Joined: Wed Jan 09, 2019 2:16 am
Location: Indianapolis, IN, USA

Re: Will LEM be available prior to Jan 20 2019 TLE? [Case So

Postby xjubier » Thu Jan 17, 2019 9:40 am

Rgalloway11 wrote:It took doing some experimenting, but I was able to finally get my 5D3 and 6D to load the script and do the hardware setup without crashing. I had to turn on my camera, take out the SD card, close the card door. Then turn on the LEM hardware setup and then plug in the USB cable and then reinsert the SD card into the camera. Sounds crazy, but it worked finally.

Yes Rick, this crashing bug is an Apple High Sierra regression that Apple never fixed although the detailed bug report I did was acknowledged. This bug doesn't exists in any other OS main version and was fixed in Mojave; in the end I was just told by Apple to tell users to upgrade to Mojave... I was really upset by this as they had many months to fix the issue which wasn't even a complex one!

Since it occurs only when the memory card isn't empty upon camera connection, what you can do is just to make sure you format the card before connecting the camera and then no need for the "double" insertion trick.
xjubier
Site Admin
 
Posts: 314
Joined: Wed Oct 01, 2008 12:35 pm
Location: France

Re: Will LEM be available prior to Jan 20 2019 TLE? [Case So

Postby Rgalloway11 » Fri Feb 01, 2019 5:30 pm

Xavier - I am happy to report very good results with LEM on Jan 20th. It was extremely cold, but I wrapped my MacBook Pro in a heating pad and it survived the bitter cold. Another well-deserved donation is on its way. If you want to see the results:
https://www.dropbox.com/sh/6os06pf9xj4z ... 7Ebsa?dl=0

Thanks again : Rick
Rgalloway11
 
Posts: 8
Joined: Wed Jan 09, 2019 2:16 am
Location: Indianapolis, IN, USA

Re: Will LEM be available prior to Jan 20 2019 TLE? [Case So

Postby xjubier » Fri Feb 01, 2019 11:41 pm

Rgalloway11 wrote:Xavier - I am happy to report very good results with LEM on Jan 20th. It was extremely cold, but I wrapped my MacBook Pro in a heating pad and it survived the bitter cold. Another well-deserved donation is on its way.
Thanks again : Rick

Happy it went well and you got some nice pics. Using a heating pad can indeed help a lot making sure the laptop runs properly.
xjubier
Site Admin
 
Posts: 314
Joined: Wed Oct 01, 2008 12:35 pm
Location: France

Previous

Return to Lunar Eclipse Maestro

Who is online

Users browsing this forum: No registered users and 1 guest

cron